Latency increase

Incident Report for Black Forest Labs

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 19:27 UTC

Investigating

We are experiencing above average load and working to mitigate this.
Posted Mar 31, 2026 - 08:41 UTC