Increased latency in EU2

Incident Report for Black Forest Labs

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 13:19 UTC

Monitoring

We've identified the issue and implemented a fix, latency is returning to normal and we'll keep monitoring.
Posted Feb 24, 2026 - 10:56 UTC

Investigating

We're investigating an increase in latency in a single EU cluster, EU2, for a few of our models.
Posted Feb 24, 2026 - 10:33 UTC