Increase Latency on our clusters

Incident Report for Black Forest Labs

Resolved

The latency issue has been resolved.
Posted Jul 29, 2025 - 09:20 UTC

Investigating

We are currently facing an increase in latency on our clusters (US & EU)
Posted Jul 25, 2025 - 15:15 UTC