EU region is experience issues

Incident Report for Black Forest Labs

Resolved

The incident has been resolved
Posted Jul 25, 2025 - 15:14 UTC

Monitoring

A fix has been implemented and we are monitoring the cluster.
Posted Jul 25, 2025 - 15:05 UTC

Update

We are still investigating the root cause.
Posted Jul 25, 2025 - 14:35 UTC

Investigating

We are currently facing an issue with our EU cluster.
Posted Jul 25, 2025 - 14:22 UTC