The incident has been resolved now, all the failed transactions will automatically be retried over the next few hours latest. You should see the credits in your account soon.
Posted Jul 22, 2025 - 09:11 UTC
Identified
We have identified the issue and are working on a fix.
Posted Jul 22, 2025 - 08:51 UTC
Investigating
We are currently investigating an issue related to credits not showing up on your account after a payment.